Home >> Forums >> Nuclear Dawn >> SDK and Community Content >> Overview Minimap Config

  • Author
    Posts
  • #37406
    Michiel
    Michiel
    Admin

    So I've been working with the overviews and I posted my progress so far on the wiki (http://wiki.nucleard…ex.php/Overview) and I managed to get a custom overview up on a sample map. However, there's a couple things I can't figure out. How did you guys (the devs) take your screenshots? I tried a couple in-game using noclip, but 1.) they ended up crooked and 2.) I can't figure out what to set the properties on the text files, because I can't really find the exact scale the map is when I'm flying in the air somewhere.

    Thanks.

    EDIT: Well, I figured out something anyway. Seems like scale and pos_x/pos_y are related by a factor of 500 somehow; e.g. to center the buildings on the overview at the center of the overview, you set x_pos = 3*-500 = -1500 and y_pos = 3*500 = 1500. It all still seems a bit arbitrary, though.

    EDIT2: One more thing. In-game, the map works correctly sometimes, and then it flickers in and out, and then there are some gray bars. Is this because of the way I saved it, or something? All I did was whip up something in paint.net (since the screenshot didn't work out) and used Nem's vtfedit to convert/write the vmt file. Example in the picture (excuse the hugeness of the points and such, this is a tiny test map).

    Nevermind, I just had to make it an UnlitGeneric, which makes sense anyways.

  • #41547

    Jeroen
    Member

    Check this tutorial, it's the same method we use for the official ND maps: http://developer.valvesoftware.com/wiki/Overview

  • #41548
    Michiel
    Michiel
    Admin

    Ah, indeed, thanks very much. I forgot that CS:S used overviews, never actually played the game.

    I'll edit this post if I need any more help.

  • #41549
    Michiel
    Michiel
    Admin

    What is the directory path to put the .vtf file in? (the over view image) I cant seem to find the correct folder to put it in.

  • #41550
    Michiel
    Michiel
    Admin
    Tontow wrote:
    What is the directory path to put the .vtf file in? (the over view image) I cant seem to find the correct folder to put it in.

    STEAMDIRsteamappscommonnuclear dawnnucleardawnmaterials

    Create the materials directory if it doesn't exist. Remember to include a .vmt file as well.

  • #41551
    Michiel
    Michiel
    Admin

    wait, I thouht you had to have it all as .vtf ?

  • #41552
    Michiel
    Michiel
    Admin

    Ok. So I stumbled on how to make .vmt files on accadent.

    Now I have my maps .vtf and .vmt in a directory named materials.

    I think I have the overview file set up correctly, but…..

    Now my minimap is zoomed out correctly and you can see the spawns and capture points, but all you can see is a checker board instead of the image.

  • #41553

    Jeroen
    Member

    Looks like the texture location wasn't setup correctly in the overview script file or vmt

    Example, material overviews/downtown // texture file Make sure that line is pointing to the right location and texture name.

    Best is to place all overview textures in materials/overviews

  • #41554
    Michiel
    Michiel
    Admin

    Ah, I forgot to add a directory named overviews inside the materials directory. Its working now.

    #41555
    Michiel
    Michiel
    Admin

    i just witness the most uncanny situation, so there i was trying to figure how to get it working, getting closer all the time, had all kinds of issues, and then suddenly it works, but, to my awe, see, my map is not a square, but the vtf for the minimap is, and the vtf itself has 2 black stripes on each side of the map, what happens is all the references in the map, my position buildings and resource points were showing up unaligned with the map, half of them on the “map” part of the minimap, the other half on the black stripe, it was aligning everything to the right, so i figured i'd go to the vtf and pull the map part down, so one of the black stripes is gone, and woah, turns out that it got even more displaced, the whole thing went nuts, what did i do? i put it back exactly like it was on the previous attempt, and voilla it's perfectly aligned, i have no clue why it wasn't doing it properly, and then it did, with the exact same files.

    Now i'd just like to remove the black sides from it, but everytime i try doing anything with alpha the whole thing either goes purple checkers or totally black.

    And one other question directed at the big bosses, there are 6 skyboxes, 6 official maps, but there's textures and commander camera for a 7th map, desert themed, missiles, highway etc… is that a map under development? Cause i have been using some of the models from it on my map, hope it's ok that i did so :S

    On the comm camera setting files there's nd_aljaber (the above mentioned), eventhough that's probably the codename for the map, since all resourse files have names of cities/places (london, NY, japan, dubai, syrdakh, vyksa (the last 2 both towns in russia) i find it weird that a quick google lookup didn't show any palce called aljaber or al jaber, but it is a name, lots of people go by it though.

    Sorry for the long post, still need help with the black sides, thank you

    Author
    Posts

You must be logged in to reply to this topic.